TreeDraw manual

TreeDraw site SpanSoft main site

TreeDraw

Getting Started

Introducing TreeDraw

Tutorials

Tutorial - Importing a tree

Tutorial - Using the drawing area

Tutorial - Printing a chart

Tasks

File handling

Starting a new chart

Opening an existing chart

Saving a chart

Saving a chart with a different name

Importing trees

Selecting a Kith and Kin Pro database

Importing from the same file again

Exporting the chart as an Adobe PDF file

Exporting the chart as a metafile

Exporting the chart as a bitmap

Preparing the chart for sending

Dropping files into TreeDraw

Changing the K&KPro database link names

Preferences | File settings

Tree import settings

Choosing import options

Preferences | Import visuals

Preferences | Import fields

Preferences | Dates

Preferences | Replace text

Preferences | Import profiles

Getting import visual styles from selection

Editing a chart

Selecting the pointer tool

Selecting chart elements

Selecting all chart elements

Adding text

Editing text

Adding lines and shapes

Adding pictures and graphics

Moving chart elements

Resizing chart elements

Joining lines to chart elements

Unjoining chart lines

Cutting to the clipboard

Copying to the clipboard

Pasting from the clipboard

Deleting chart elements

Grouping chart elements together

Ungrouping chart elements

Updating text automatically

Undoing the previous operation

Redoing the subsequent operation

Undoing several operations

Scaling the chart

Formatting

Setting text font

Setting text alignment

Setting text rotation

Setting word wrapping

Changing a text element's link to a K&KPro database

Selecting a family to use in a database link

Selecting a person to use in a database link

Setting the line style

Choosing a line style

Setting the shape fill pattern

Setting colours

Repeating the last format change

Getting default styles from selection

Alignment

Changing the order of chart elements

Aligning chart elements horizontally

Aligning chart elements vertically

Spacing chart elements evenly

Centring curved lines

Screen

Using the magnifier

Enlarging text

Turning the snap-to-grid on and off

Displaying page-breaks

Using the ruler

Moving around the drawing area

Zooming in and out

Searching for text

Turning the Colour Palette on and off

Turning the Chart View Control on and off

Turning the Button Bar on and off

Customising the Button Bar

Turning the Status Bar on and off

Preferences | Appearance

Printing

Printing a chart

Selecting pages to print

Setting page size/margins/orientation/footer

Setting a user-defined paper size

Setting up the printer

General

Setting preferences

Preferences | General

Exiting from the program

Backing-up your data

Checking for program updates

Using the Chart View Control

Reference

File menu

Edit menu

Format menu

Align menu

Tools menu

View menu

Options menu

Database fields

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

Kith and Kin Pro

GEDCOM

LDS

How to get support

How to contact us

Large-format printing service

Ordering / registration

Version information

This is a list of new features, enhancements and bug fixes which is updated with the release of each new version of TreeDraw.

Version 4.2.0   Jan 2014

Minor upgrade

Adds the ability to set default formatting styles based on the current selection.

Adds the ability to set visual import styles based on the current selection.

Adds the ability to set the vertical snap-to-grid spacing based on the current selection.

Removes inapplicable commands from the Drawing Area popup menu.

Fixes missing Format | Font default settings after selecting multiple text elements.

Fixes mis-match between Format | Text alignment setting in main menu and popup menu.

Version 4.1.2   Oct 2013

Bug-fix release

Fixes problems using Undo/Redo.

Fixes crashes in charts which have joined lines.

Version 4.1.1   July 2013

Bug-fix release

Italic text elements were wrapping before the last word when they should have been single-line.

Word-wrapped text elements sometimes wrapped differently when in edit mode.

If linked databases are missing these are now reported summarized after an "Update text" operation.

Version 4.1.0   May 2013

Minor upgrade

Adds Database Link command to drawing area popup menu.

More informative "Invalid format" error messages in "Preferences | Import fields".

Version 4.0.5   Jan 2013

Bug-fix release

Importing a chart with a blank import format resulted in a "List index out of bounds" error.

Import formats can no longer be blank.

Changing the Windows regional number format caused a floating-point error when starting TreeDraw.

Version 4.0.4   June 2012

Minor upgrade

Adds a direct link to the online video tutorials in the Help menu.

Version 4.0.3   March 2012

Bug-fix release

Various installation changes to meet Windows Certification criteria. Some system files have been moved to different folders.

The TreeDraw_Temp database folder has been moved to Users\<username>\AppData\Roaming\TreeDraw.

The options file TreeDraw.ini is now stored in Users\<username>\AppData\Roaming\TreeDraw. This means that each Windows user will have their own options settings.

Fixes the TreeDraw.ini file access issue when logged into Windows without administrator privileges.

The version 1 chart file conversion utility is now installed as an archive file V1_FileConversion.zip. This is to meet the Windows criteria of not installing 16-bit software.

Version 4.0.2   March 2012

Bug-fix release

Long children connecting lines are now also joined to the lines at their ends.

Added image compression/quality option to PDF file exports.

Chart View Control was not hidden when minimized under Vista/Win7.

Colour Palette was not hidden when minimized under Vista/Win7.

Exporting a PDF file with a large number of hi-res images created a blank file.

The lines in a wheel chart were hidden when "Group tree elements" was selected.

The ruler no longer sits on top of the magnifier when used.

Version 4.0.1   Jan 2012

Bug-fix release

PCs running Vista/Win7 with UAC turned on gave a warning when starting TreeDraw.

Version 4.0.0   Jan 2012

Major upgrade

Joined lines added. Straight lines can have their ends joined to any other chart element so that the line stretches when the element is moved.

Descendant and ancestral trees can join up lines automatically.

Multiple levels of undo allow you to step back through changes you made to the current chart.

Right-clicking in the Drawing Area to pop up a context menu added.

Add images direct from a scanner.

The size of the element handles can be user-defined.

The length of the lines linked to text in imported charts can be user-defined.

Option to import full resolution pictures instead of thumbnails.

Change priority of items in the Replace Text list.

Buttonbar buttons can be made small or large.

TreeDraw uses the look-and-feel of the current Windows theme under XP, Vista and Win7.

Descendant and ancestral trees which created two small lines end-to-end now create just one line instead.

"Preferences | Import graphics" renamed "Import visuals".

"Preferences | Options" renamed "General".

Correctly shows taskbar thumbnail when minimized under Vista and Win7.

Fixed - "Format | Pattern" set the pattern for the Drawing Area.

Fixed - No greyed handles for arc elements when multiple elements selected.

Fixed - Copy/Paste and Metafile cropping.

Windows XP, Vista, Win7 or later required. Will not run under Win98 or WinMe.

Download genealogy software for family history research. Our free to try genealogy software is for family history research. Download TreeDraw to print charts from family tree software, it is free to try. We specialize in free to try genealogy software, available for download. Try our genealogy charting software for free. You can download genealogy software for family history. TreeDraw is a charting program for your family history. Download genealogy chart program for use with GEDCOM compatible software. Free 30-day trial. You can download genealogy software, free trial, to print your family history. Download genealogy software here for GEDCOM. This site is about genealogy and family history software with free trial software. TreeDraw imports GEDCOM files and produces genealogy charts. Print family trees with our free to try genealogy software. Our family history software is free to try and is used for genealogy. Genealogy software is sometimes mispelled as geneology software. TreeDraw is a genealogy chart program, download it here.