TreeDraw manual

TreeDraw site SpanSoft main site

TreeDraw

Getting Started

Introducing TreeDraw

Tutorials

Tutorial - Importing a tree

Tutorial - Using the drawing area

Tutorial - Printing a chart

Tasks

File handling

Starting a new chart

Opening an existing chart

Saving a chart

Saving a chart with a different name

Importing trees

Selecting a Kith and Kin Pro database

Importing from the same file again

Exporting the chart as an Adobe PDF file

Exporting the chart as a metafile

Exporting the chart as a bitmap

Preparing the chart for sending

Dropping files into TreeDraw

Changing the K&KPro database link names

Preferences | File settings

Tree import settings

Choosing import options

Preferences | Import visuals

Preferences | Import fields

Preferences | Dates

Preferences | Replace text

Preferences | Import profiles

Getting import visual styles from selection

Editing a chart

Selecting the pointer tool

Selecting chart elements

Selecting all chart elements

Adding text

Editing text

Adding lines and shapes

Adding pictures and graphics

Moving chart elements

Resizing chart elements

Joining lines to chart elements

Unjoining chart lines

Cutting to the clipboard

Copying to the clipboard

Pasting from the clipboard

Deleting chart elements

Grouping chart elements together

Ungrouping chart elements

Updating text automatically

Undoing the previous operation

Redoing the subsequent operation

Undoing several operations

Scaling the chart

Formatting

Setting text font

Setting text alignment

Setting text rotation

Setting word wrapping

Changing a text element's link to a K&KPro database

Selecting a family to use in a database link

Selecting a person to use in a database link

Setting the line style

Choosing a line style

Setting the shape fill pattern

Setting colours

Repeating the last format change

Getting default styles from selection

Alignment

Changing the order of chart elements

Aligning chart elements horizontally

Aligning chart elements vertically

Spacing chart elements evenly

Centring curved lines

Screen

Using the magnifier

Enlarging text

Turning the snap-to-grid on and off

Displaying page-breaks

Using the ruler

Moving around the drawing area

Zooming in and out

Searching for text

Turning the Colour Palette on and off

Turning the Chart View Control on and off

Turning the Button Bar on and off

Customising the Button Bar

Turning the Status Bar on and off

Preferences | Appearance

Printing

Printing a chart

Selecting pages to print

Setting page size/margins/orientation/footer

Setting a user-defined paper size

Setting up the printer

General

Setting preferences

Preferences | General

Exiting from the program

Backing-up your data

Checking for program updates

Using the Chart View Control

Reference

File menu

Edit menu

Format menu

Align menu

Tools menu

View menu

Options menu

Database fields

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

Kith and Kin Pro

GEDCOM

LDS

How to get support

How to contact us

Large-format printing service

Ordering / registration

Tutorial - Printing a chart

This tutorial requires the sample chart supplied with the program - use "File | Open" and choose "Sample.tdr"

Subjects: Setting page options, selecting pages, printing a chart.

If it is not already open, use "File | Open" to open the Sample.tdr file. If the chart is not visible, use Ctrl+A to select everything and then Ctrl+N to select normal viewing which also has the effect of scrolling to the selected elements. Left-click on nothing to de-select the chart elements.

 
Page settings

Before printing the chart you should check that the page settings are correct for your printer. Click on "File | Page setup" to display the current page and printer settings.

 
Printer settings

This displays the current printer and paper source. If you want to change these click on the "Setup" button.

 
Measure

If you prefer to work in millimetres, click on the mm option.

 
Page size

The sample chart is designed to print on an A4 sheet. If your paper is different, click on the arrow to the right of the page size description and select your paper size from the drop-down list. If your paper size is not listed you can type the dimensions into the "Width" and "Height" boxes.

 
Orientation

Choose portrait or landscape to tell the printer which direction the chart should be printed on the page. The sample chart is designed to print landscape.

 
Margins

Make sure that the page margins are greater than your printer's non-printing area around the edge of the paper. TreeDraw will check this automatically when you click on the OK button.

 
Page footer

There are several optional items which can be printed at the bottom of each page. Again, make sure that the "Distance from bottom of page" is greater than your printer's non-printing area. It is usually best to choose a distance which prints the footer within the bottom margin. This stops the footer overprinting parts of the chart.

You can change the font used to print the footer in "Options | Preferences | Appearance".

 
Selecting the pages to print

Before you can print a chart you must tell TreeDraw which pages you want to print; the drawing area contains millions of pages!

Click on "Options | Display page breaks" to turn on the page-breaks display if it is not already on. To see the chart better, press "Ctrl+O" three times to zoom out to 20%. You will now be able to see dotted red lines which mark the edges of each page. Note that the sizes of the displayed pages exclude the page margins so a chart line which crosses a vertical page break on the screen will stop at the right margin of one page and resume again at the left margin of the next page when printed. The sample chart already has the top-left page selected and this is indicated by a solid red border around this one page.

To change which pages are selected, click on "Tools | Select pages" or on the Select pages button. Drag the mouse around the drawing area with the left mouse button down. You will see an expanding rectangle follow the cursor around the screen. When it covers the pages you want to print release the mouse button. Note that TreeDraw stores which pages are selected in a particular chart inside the chart's (.tdr) file so that the next time you open the chart file, the correct pages will be selected.

 
Printing

Click on the Print button or click on "File | Print" to start printing the selected pages. The status bar at the bottom of the TreeDraw window will show the progress of the print operation. If you want to abort the printout, click on the small abort button next to the progress display or press the Esc key.

See also

Download genealogy software for family history research. Our free to try genealogy software is for family history research. Download TreeDraw to print charts from family tree software, it is free to try. We specialize in free to try genealogy software, available for download. Try our genealogy charting software for free. You can download genealogy software for family history. TreeDraw is a charting program for your family history. Download genealogy chart program for use with GEDCOM compatible software. Free 30-day trial. You can download genealogy software, free trial, to print your family history. Download genealogy software here for GEDCOM. This site is about genealogy and family history software with free trial software. TreeDraw imports GEDCOM files and produces genealogy charts. Print family trees with our free to try genealogy software. Our family history software is free to try and is used for genealogy. Genealogy software is sometimes mispelled as geneology software. TreeDraw is a genealogy chart program, download it here.