TreeDraw manual

TreeDraw site SpanSoft main site

TreeDraw

Getting Started

Introducing TreeDraw

Tutorials

Tutorial - Importing a tree

Tutorial - Using the drawing area

Tutorial - Printing a chart

Tasks

File handling

Starting a new chart

Opening an existing chart

Saving a chart

Saving a chart with a different name

Importing trees

Selecting a Kith and Kin Pro database

Importing from the same file again

Exporting the chart as an Adobe PDF file

Exporting the chart as a metafile

Exporting the chart as a bitmap

Preparing the chart for sending

Dropping files into TreeDraw

Changing the K&KPro database link names

Preferences | File settings

Tree import settings

Choosing import options

Preferences | Import visuals

Preferences | Import fields

Preferences | Dates

Preferences | Replace text

Preferences | Import profiles

Getting import visual styles from selection

Editing a chart

Selecting the pointer tool

Selecting chart elements

Selecting all chart elements

Adding text

Editing text

Adding lines and shapes

Adding pictures and graphics

Moving chart elements

Resizing chart elements

Joining lines to chart elements

Unjoining chart lines

Cutting to the clipboard

Copying to the clipboard

Pasting from the clipboard

Deleting chart elements

Grouping chart elements together

Ungrouping chart elements

Updating text automatically

Undoing the previous operation

Redoing the subsequent operation

Undoing several operations

Scaling the chart

Formatting

Setting text font

Setting text alignment

Setting text rotation

Setting word wrapping

Changing a text element's link to a K&KPro database

Selecting a family to use in a database link

Selecting a person to use in a database link

Setting the line style

Choosing a line style

Setting the shape fill pattern

Setting colours

Repeating the last format change

Getting default styles from selection

Alignment

Changing the order of chart elements

Aligning chart elements horizontally

Aligning chart elements vertically

Spacing chart elements evenly

Centring curved lines

Screen

Using the magnifier

Enlarging text

Turning the snap-to-grid on and off

Displaying page-breaks

Using the ruler

Moving around the drawing area

Zooming in and out

Searching for text

Turning the Colour Palette on and off

Turning the Chart View Control on and off

Turning the Button Bar on and off

Customising the Button Bar

Turning the Status Bar on and off

Preferences | Appearance

Printing

Printing a chart

Selecting pages to print

Setting page size/margins/orientation/footer

Setting a user-defined paper size

Setting up the printer

General

Setting preferences

Preferences | General

Exiting from the program

Backing-up your data

Checking for program updates

Using the Chart View Control

Reference

File menu

Edit menu

Format menu

Align menu

Tools menu

View menu

Options menu

Database fields

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

Kith and Kin Pro

GEDCOM

LDS

How to get support

How to contact us

Large-format printing service

Ordering / registration

Importing trees

Descendant trees start from a particular ancestor and work down through their descendants:

Ancestral trees start from a particular descendant and work up through their ancestors:

Wheel charts start from a particular descendant and work up through their ancestors:

 
You can also drag and drop a GEDCOM file into TreeDraw to begin the import process.

If you have already imported a particular type of tree and want to re-import it see "Importing from the same file again".

You can create a new tree in your chart (more than one tree can be imported into the same chart) from one of two sources; Kith and Kin Pro databases or GEDCOM files. If you do not have Kith and Kin Pro on your PC, TreeDraw will only let you import GEDCOM files. Kith and Kin Pro users can import from either source.

Having selected the type of tree you want to import, you will see either the "Import Kith and Kin Pro database" dialog or the "Import GEDCOM file" dialog. If you want to switch to the other source, click on the "GEDCOM" or "Kith and Kin" button as appropriate. Select the source database or file that you want to import from.

Some additional options are available when you have selected a GEDCOM file.

When the import is complete (Kith and Kin Pro databases are not actually imported; data is read direct from the database) you will see a dialog headed "Import descendant/ancestral tree or wheel chart from <filename>". You can now select the root person and additional options which determine the layout of the imported tree.

If you have the snap-to grid option on, you will then be asked if you want the program to adjust the vertical spacing of the grid to match the Names font size. Replying Yes to this will ensure that the tree is correctly spaced and easy to modify afterwards.

As TreeDraw imports the chart, dates will be formatted using the settings in "Options | Preferences | Import dates" and it will also check if there is any text to be replaced, as defined in "Options | Preferences | Replace text".

When the tree has been drawn, all its elements (and only its elements) will be selected to allow you to move the whole tree to a new location in the chart. Note that the drawing area will scroll automatically so that the new tree is in view.

TreeDraw maintains a link between each imported text element and the database/table/field it originated from. This allows you to update your tree to match any textual changes in the original tree file without having to re-import the tree. You can also modify or lock this link. This does not apply to wheel charts since the lines of text have been split so that they can be rotated correctly.

See also