TreeDraw manual

TreeDraw site SpanSoft main site

TreeDraw

Getting Started

Introducing TreeDraw

Tutorials

Tutorial - Importing a tree

Tutorial - Using the drawing area

Tutorial - Printing a chart

Tasks

File handling

Starting a new chart

Opening an existing chart

Saving a chart

Saving a chart with a different name

Importing trees

Selecting a Kith and Kin Pro database

Importing from the same file again

Exporting the chart as an Adobe PDF file

Exporting the chart as a metafile

Exporting the chart as a bitmap

Preparing the chart for sending

Dropping files into TreeDraw

Changing the K&KPro database link names

Preferences | File settings

Tree import settings

Choosing import options

Preferences | Import visuals

Preferences | Import fields

Preferences | Dates

Preferences | Replace text

Preferences | Import profiles

Getting import visual styles from selection

Editing a chart

Selecting the pointer tool

Selecting chart elements

Selecting all chart elements

Adding text

Editing text

Adding lines and shapes

Adding pictures and graphics

Moving chart elements

Resizing chart elements

Joining lines to chart elements

Unjoining chart lines

Cutting to the clipboard

Copying to the clipboard

Pasting from the clipboard

Deleting chart elements

Grouping chart elements together

Ungrouping chart elements

Updating text automatically

Undoing the previous operation

Redoing the subsequent operation

Undoing several operations

Scaling the chart

Formatting

Setting text font

Setting text alignment

Setting text rotation

Setting word wrapping

Changing a text element's link to a K&KPro database

Selecting a family to use in a database link

Selecting a person to use in a database link

Setting the line style

Choosing a line style

Setting the shape fill pattern

Setting colours

Repeating the last format change

Getting default styles from selection

Alignment

Changing the order of chart elements

Aligning chart elements horizontally

Aligning chart elements vertically

Spacing chart elements evenly

Centring curved lines

Screen

Using the magnifier

Enlarging text

Turning the snap-to-grid on and off

Displaying page-breaks

Using the ruler

Moving around the drawing area

Zooming in and out

Searching for text

Turning the Colour Palette on and off

Turning the Chart View Control on and off

Turning the Button Bar on and off

Customising the Button Bar

Turning the Status Bar on and off

Preferences | Appearance

Printing

Printing a chart

Selecting pages to print

Setting page size/margins/orientation/footer

Setting a user-defined paper size

Setting up the printer

General

Setting preferences

Preferences | General

Exiting from the program

Backing-up your data

Checking for program updates

Using the Chart View Control

Reference

File menu

Edit menu

Format menu

Align menu

Tools menu

View menu

Options menu

Database fields

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

Kith and Kin Pro

GEDCOM

LDS

How to get support

How to contact us

Large-format printing service

Ordering / registration

Changing a text element's link to a K&KPro database

When you import a tree from a Kith and Kin Pro database, each new text element stores a link to the database/table/record/field(s) which were used to create it. When you use the Update text or Auto-update text functions, TreeDraw uses the link attributes stored which each text element to update the text. You can also use this command to set up a database link for text which was not imported but added manually.

This command allows you to change the attributes of a text element's link.

Before using the command, select the single text element which you want to change the link for.

When only one chart element is selected it has small handles around it like this:

and the Status bar will show "Selected: 1".

 
Database that this text is linked to

The full path of the Kith and Kin Pro database which will be used to update the text in this element. To choose a database which is already used in this chart, click on the drop down button to the right of the edit box and select the required database. If you want to choose a new database, click on the Browse button.

 
Browse

Select the database which you want to use to update the text in this element.

 
Person

This text is part of a person's name or details.

 
Family

This text is part of a family's/marriage's details.

 
Person code / Family code

Enter the Kith and Kin Pro code of the person, family or event which this text relates to.

 
Select

If you don't know the code, click on this button to select the appropriate person or family.

 
Import format

Tells TreeDraw which database fields to use and how to lay them out. Works the same way as the "Options | Preferences | Import fields" settings.

 
Locked

Set this option to prevent this particular text element from being updated during an Update Text operation.

 
Clear

Removes all link settings from this text element.

 
Data type

These are the standard data formats available for a person, family or event as defined in "Options | Preferences | Import fields". If you want to use one of these standard formats, drag it from here into the "Import format" box. It will replace any format currently in the "Import format" box.

 
Fields available

Displays the database fields available for a person or family in the currently selected database. If you want to add a field to the "Import format" box, drag it from here.

See also

Download genealogy software for family history research. Our free to try genealogy software is for family history research. Download TreeDraw to print charts from family tree software, it is free to try. We specialize in free to try genealogy software, available for download. Try our genealogy charting software for free. You can download genealogy software for family history. TreeDraw is a charting program for your family history. Download genealogy chart program for use with GEDCOM compatible software. Free 30-day trial. You can download genealogy software, free trial, to print your family history. Download genealogy software here for GEDCOM. This site is about genealogy and family history software with free trial software. TreeDraw imports GEDCOM files and produces genealogy charts. Print family trees with our free to try genealogy software. Our family history software is free to try and is used for genealogy. Genealogy software is sometimes mispelled as geneology software. TreeDraw is a genealogy chart program, download it here.