TreeDraw manual

TreeDraw site SpanSoft main site

TreeDraw

Getting Started

Introducing TreeDraw

Tutorials

Tutorial - Importing a tree

Tutorial - Using the drawing area

Tutorial - Printing a chart

Tasks

File handling

Starting a new chart

Opening an existing chart

Saving a chart

Saving a chart with a different name

Importing trees

Selecting a Kith and Kin Pro database

Importing from the same file again

Exporting the chart as an Adobe PDF file

Exporting the chart as a metafile

Exporting the chart as a bitmap

Preparing the chart for sending

Dropping files into TreeDraw

Changing the K&KPro database link names

Preferences | File settings

Tree import settings

Choosing import options

Preferences | Import visuals

Preferences | Import fields

Preferences | Dates

Preferences | Replace text

Preferences | Import profiles

Getting import visual styles from selection

Editing a chart

Selecting the pointer tool

Selecting chart elements

Selecting all chart elements

Adding text

Editing text

Adding lines and shapes

Adding pictures and graphics

Moving chart elements

Resizing chart elements

Joining lines to chart elements

Unjoining chart lines

Cutting to the clipboard

Copying to the clipboard

Pasting from the clipboard

Deleting chart elements

Grouping chart elements together

Ungrouping chart elements

Updating text automatically

Undoing the previous operation

Redoing the subsequent operation

Undoing several operations

Scaling the chart

Formatting

Setting text font

Setting text alignment

Setting text rotation

Setting word wrapping

Changing a text element's link to a K&KPro database

Selecting a family to use in a database link

Selecting a person to use in a database link

Setting the line style

Choosing a line style

Setting the shape fill pattern

Setting colours

Repeating the last format change

Getting default styles from selection

Alignment

Changing the order of chart elements

Aligning chart elements horizontally

Aligning chart elements vertically

Spacing chart elements evenly

Centring curved lines

Screen

Using the magnifier

Enlarging text

Turning the snap-to-grid on and off

Displaying page-breaks

Using the ruler

Moving around the drawing area

Zooming in and out

Searching for text

Turning the Colour Palette on and off

Turning the Chart View Control on and off

Turning the Button Bar on and off

Customising the Button Bar

Turning the Status Bar on and off

Preferences | Appearance

Printing

Printing a chart

Selecting pages to print

Setting page size/margins/orientation/footer

Setting a user-defined paper size

Setting up the printer

General

Setting preferences

Preferences | General

Exiting from the program

Backing-up your data

Checking for program updates

Using the Chart View Control

Reference

File menu

Edit menu

Format menu

Align menu

Tools menu

View menu

Options menu

Database fields

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

Kith and Kin Pro

GEDCOM

LDS

How to get support

How to contact us

Large-format printing service

Ordering / registration

Setting colours

If the colour palette is not visible then:

The colour palette is used to define the colour(s) of chart elements and also the default colour(s) for new elements.

If no elements are selected, the default colours (applied to new elements) will be changed. The caption at the top of the colour palette indicates whether you are changing the colours for the selected elements or the default colours.

The "Line colour" box shows the colour for lines, shape outlines and text. The "Fill colour" box (if present) shows the colour for the filled area of shapes. In the example above these are black and white respectively.

Click on a colour square with the left mouse button to change the Line colour.

Click on a colour square with the right mouse button to change the Fill colour.

The 16 standard Windows colours are always available on the palette. You can also select any other colour by double-clicking on either of the last two colour squares - the custom colour squares (in the example above one has been changed to orange). This opens the standard Windows colour dialog where you can choose any colour. When you click OK the new colour appears in the colour square and you can then select it just like any of the other 16 colours.

If you left click on the "Line colour" box, the current line colour will appear in the first custom colour square. Right click to have the line colour appear in the second custom colour square. This allows you to prefill the custom colour squares with the colour of, say, a selected element and then you can adjust this colour by double-clicking on the custom colour square. You can do exactly the same with the "Fill colour" box.

The colour palette may be moved anywhere on the screen.

See also