TreeDraw manual

TreeDraw site SpanSoft main site

TreeDraw

Getting Started

Introducing TreeDraw

Tutorials

Tutorial - Importing a tree

Tutorial - Using the drawing area

Tutorial - Printing a chart

Tasks

File handling

Starting a new chart

Opening an existing chart

Saving a chart

Saving a chart with a different name

Importing trees

Selecting a Kith and Kin Pro database

Importing from the same file again

Exporting the chart as an Adobe PDF file

Exporting the chart as a metafile

Exporting the chart as a bitmap

Preparing the chart for sending

Dropping files into TreeDraw

Changing the K&KPro database link names

Preferences | File settings

Tree import settings

Choosing import options

Preferences | Import visuals

Preferences | Import fields

Preferences | Dates

Preferences | Replace text

Preferences | Import profiles

Getting import visual styles from selection

Editing a chart

Selecting the pointer tool

Selecting chart elements

Selecting all chart elements

Adding text

Editing text

Adding lines and shapes

Adding pictures and graphics

Moving chart elements

Resizing chart elements

Joining lines to chart elements

Unjoining chart lines

Cutting to the clipboard

Copying to the clipboard

Pasting from the clipboard

Deleting chart elements

Grouping chart elements together

Ungrouping chart elements

Updating text automatically

Undoing the previous operation

Redoing the subsequent operation

Undoing several operations

Scaling the chart

Formatting

Setting text font

Setting text alignment

Setting text rotation

Setting word wrapping

Changing a text element's link to a K&KPro database

Selecting a family to use in a database link

Selecting a person to use in a database link

Setting the line style

Choosing a line style

Setting the shape fill pattern

Setting colours

Repeating the last format change

Getting default styles from selection

Alignment

Changing the order of chart elements

Aligning chart elements horizontally

Aligning chart elements vertically

Spacing chart elements evenly

Centring curved lines

Screen

Using the magnifier

Enlarging text

Turning the snap-to-grid on and off

Displaying page-breaks

Using the ruler

Moving around the drawing area

Zooming in and out

Searching for text

Turning the Colour Palette on and off

Turning the Chart View Control on and off

Turning the Button Bar on and off

Customising the Button Bar

Turning the Status Bar on and off

Preferences | Appearance

Printing

Printing a chart

Selecting pages to print

Setting page size/margins/orientation/footer

Setting a user-defined paper size

Setting up the printer

General

Setting preferences

Preferences | General

Exiting from the program

Backing-up your data

Checking for program updates

Using the Chart View Control

Reference

File menu

Edit menu

Format menu

Align menu

Tools menu

View menu

Options menu

Database fields

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

Kith and Kin Pro

GEDCOM

LDS

How to get support

How to contact us

Large-format printing service

Ordering / registration

Tutorial - Using the drawing area

This tutorial requires the sample chart supplied with the program - use "File | Open" and choose "Sample.tdr"

Subjects: Moving around the chart, zooming in and out, selecting elements, moving elements, adding lines and shapes, adding text, editing text, adding pictures, resizing elements.

If it is not already open, use "File | Open" to open the Sample.tdr file. If the chart is not visible, use Ctrl+A to select everything and then Ctrl+N to select normal viewing which also has the effect of scrolling to the selected elements. Left-click on nothing to de-select the chart elements.

 
Moving around the chart

You'll notice that TreeDraw does not have standard scrollbars for scrolling around the drawing area. This is because the drawing area is so large. Instead, TreeDraw has more versatile controls which allow you to scroll in all directions, not just horizontally and vertically and at varying speeds.

Drag with the right mouse button to scroll the drawing area; the cursor will change to

For backwards compatibility there is also an alternative control called the Chart view control which you can access using "View | Chart view control".

 
Zooming in and out

Scroll around until you find the picture in the sample chart. Now place the mouse cursor over the picture and click the left mouse button. Four small squares will appear at the corners of the picture. This indicates that the picture has been selected. It is useful to do this before zooming in or out because it keeps the drawing area centred on the selection, otherwise the chart tends to disappear off to the side.

Now click on the "Zoom out" button alt=""/>img src="../images/outbtn.png"> on the button bar. You can now see more of the chart and the elements have been scaled down. You can keep clicking on the "Zoom out" button to zoom further and further out.

Notice that each time you zoom out, the "Zoom" number on the status bar at the bottom of the screen changes. A scale of, say, 50% indicates that the chart is displayed at half its normal size.

Return to normal scale by either clicking on the "Normal view" button or by pressing Ctrl+N or by repeatedly clicking on the zoom in button until the scale is 100%.

You can also zoom by using the mouse wheel, up zooms in, down zooms out and clicking the wheel or middle mouse button will return to normal (100%) view.

 
Selecting elements

You have already seen that you can select individual elements just by clicking on them. To do any selecting, you must first make sure that you are using the pointer tool. You can select this quickly by clicking the right mouse button anywhere on the drawing area.

If you want to select more than one element you can hold down the Shift key and click on each element in turn. A faster method is to use the selection marquee. Hold down the left mouse button with the mouse cursor over nothing in the drawing area; it's important that the cursor does not start over an element. Now drag the mouse with the left button down until the expanding rectangle covers a part of all the elements you want to select. When you release the mouse button the elements will become selected. You can also use the marquee with the Shift key.

Selected elements are enclosed by small squares called "handles". When only one element is selected you can use the handles to resize the element.

This is what an element looks like when it is the only selected element:

This is what more than one selected element looks like:

This is what a selected group looks like:

 
Moving elements

When elements are selected you can move them around the drawing area simply by holding down the left mouse button and dragging the element(s) to their new position and releasing the mouse button. Whilst an element is being moved it appears as a dotted outline; the element itself does not move until the mouse button is released.

If the snap-to-grid feature is turned on, the outlines will appear to jump from one grid point to the next.

 
Adding lines and shapes

You can add extra lines, rectangles and ovals to your chart.

Simply select the tool for the line or shape you want from the Tools menu or click on the appropriate button. Hold down the left mouse button with the mouse cursor at the point in the drawing area where you want the line or shape to start. Drag the mouse until the new element is the correct size and release the mouse button.

To select the pointer tool (ie. to stop adding more lines or shapes), right-click on the drawing area.

 
Adding text

You can add extra text to your chart.

Simply select "Tools | Text" or click on the "New text" button. Click on the point in the drawing area where you want the text to start. A narrow box will appear with a flashing vertical bar. Type the new text in here; the box will change shape to accommodate the text as it is typed. When you have finished press the Return (Enter) key. If you want to add line-breaks to the new text use Ctrl+Return.

To cancel the add operation press the Esc key.

To select the pointer tool (ie. to stop adding more text), right-click on the drawing area.

 
Editing text

To edit an existing text element, simply double-click on it.

In the sample chart, locate "[P337] James GORDON"; just to the right of the picture. Click on his name. Notice that the handles which appear are grey and some are hollow. This indicates that the text is part of a group. You cannot edit text while it is still part of a group. Click on "Edit | Ungroup" or click on the "Ungroup" button. All the handles are now solid grey which indicates that the elements are not part of a group but that there is now more than one element selected. Click somewhere just below "b. Jun 1872 Clackmannan" to de-select the elements. Now double-click on "[P337] James GORDON". The text edit box appears around the text allowing you to change the text. Press the Return or Esc key to finish the edit as before.

 
Adding pictures

There are two ways to manually add pictures and clip-art to a TreeDraw chart.

The first way is to drag an image file from Windows Explorer and drop it into the main TreeDraw window. You will see an outline of the picture appear in TreeDraw; drag the outline to an appropriate position and click the mouse.

The second way is to paste an image from the clipboard. Open the image in another program and use the program's "Edit | Copy" command. Switch to TreeDraw and use "Edit | Paste". Again, you will see an outline of the picture appear in TreeDraw; drag the outline to an appropriate position and click the mouse.

 
Resizing elements

When you have elements on your chart, you can change the size and shape of them by dragging the handles.

Find the picture in the sample chart and select it. Now place the mouse cursor over one of the four handles and hold down the left mouse button. The handles will disappear but a dotted outline will appear. Drag the mouse until the size of the outline changes. Release the mouse button and the picture will change size to fit the outline. Notice that the overall shape of the picture probably changed during that operation. If you want to maintain the shape of the picture (the aspect ratio), do the same again but use the right mouse button instead of the left.

If the snap-to-grid feature is turned on, the outlines will appear to jump from one grid point to the next.

 
Next tutorial - Printing a chart

See also

Download genealogy software for family history research. Our free to try genealogy software is for family history research. Download TreeDraw to print charts from family tree software, it is free to try. We specialize in free to try genealogy software, available for download. Try our genealogy charting software for free. You can download genealogy software for family history. TreeDraw is a charting program for your family history. Download genealogy chart program for use with GEDCOM compatible software. Free 30-day trial. You can download genealogy software, free trial, to print your family history. Download genealogy software here for GEDCOM. This site is about genealogy and family history software with free trial software. TreeDraw imports GEDCOM files and produces genealogy charts. Print family trees with our free to try genealogy software. Our family history software is free to try and is used for genealogy. Genealogy software is sometimes mispelled as geneology software. TreeDraw is a genealogy chart program, download it here.