TreeDraw manual

TreeDraw site SpanSoft main site

TreeDraw

Getting Started

Introducing TreeDraw

Tutorials

Tutorial - Importing a tree

Tutorial - Using the drawing area

Tutorial - Printing a chart

Tasks

File handling

Starting a new chart

Opening an existing chart

Saving a chart

Saving a chart with a different name

Importing trees

Selecting a Kith and Kin Pro database

Importing from the same file again

Exporting the chart as an Adobe PDF file

Exporting the chart as a metafile

Exporting the chart as a bitmap

Preparing the chart for sending

Dropping files into TreeDraw

Changing the K&KPro database link names

Preferences | File settings

Tree import settings

Choosing import options

Preferences | Import visuals

Preferences | Import fields

Preferences | Dates

Preferences | Replace text

Preferences | Import profiles

Getting import visual styles from selection

Editing a chart

Selecting the pointer tool

Selecting chart elements

Selecting all chart elements

Adding text

Editing text

Adding lines and shapes

Adding pictures and graphics

Moving chart elements

Resizing chart elements

Joining lines to chart elements

Unjoining chart lines

Cutting to the clipboard

Copying to the clipboard

Pasting from the clipboard

Deleting chart elements

Grouping chart elements together

Ungrouping chart elements

Updating text automatically

Undoing the previous operation

Redoing the subsequent operation

Undoing several operations

Scaling the chart

Formatting

Setting text font

Setting text alignment

Setting text rotation

Setting word wrapping

Changing a text element's link to a K&KPro database

Selecting a family to use in a database link

Selecting a person to use in a database link

Setting the line style

Choosing a line style

Setting the shape fill pattern

Setting colours

Repeating the last format change

Getting default styles from selection

Alignment

Changing the order of chart elements

Aligning chart elements horizontally

Aligning chart elements vertically

Spacing chart elements evenly

Centring curved lines

Screen

Using the magnifier

Enlarging text

Turning the snap-to-grid on and off

Displaying page-breaks

Using the ruler

Moving around the drawing area

Zooming in and out

Searching for text

Turning the Colour Palette on and off

Turning the Chart View Control on and off

Turning the Button Bar on and off

Customising the Button Bar

Turning the Status Bar on and off

Preferences | Appearance

Printing

Printing a chart

Selecting pages to print

Setting page size/margins/orientation/footer

Setting a user-defined paper size

Setting up the printer

General

Setting preferences

Preferences | General

Exiting from the program

Backing-up your data

Checking for program updates

Using the Chart View Control

Reference

File menu

Edit menu

Format menu

Align menu

Tools menu

View menu

Options menu

Database fields

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

Kith and Kin Pro

GEDCOM

LDS

How to get support

How to contact us

Large-format printing service

Ordering / registration

Preferences | GEDCOM

If you want to import additional fields from a GEDCOM file which do not have corresponding fields in the default TreeDraw temporary database (the one it uses for importing GEDCOM files), then you can add your own fields to import the extra data into. You can then use these fields in the "Import fields" settings to tell TreeDraw what to do with the extra data.

 
Person fields / Family fields

Select whether you want to edit the extra fields for person data or family data.

 
Current fields

This list shows the fields already added for people or families.

 
Adding a new field

Enter a unique name for the field in the Field name box. Field names must start with a letter (A to Z).

You must associate a GEDCOM tag with the new field. Different tags are available for people and families. For example, if you have added an "Occupation" field you could associate the GEDCOM tag "OCCU" with this field. Now when you import a GEDCOM file, any data with an "OCCU" tag will be put in the "Occupation" field.

The "GEDCOM tag" list shows all the available tags, some have sub-tags which are accessed by clicking on the small "+" beside the main tag. Clicking on a tag will make the expanded tag appear in the box above the list; so clicking on "AGE" in the "DEAT" tag will display "INDI DEAT AGE", indicating that this field relates to the AGE tag subordinate to the DEAT tag subordinate to the INDI (individual) tag in a GEDCOM file. It requires some knowledge of GEDCOM to know which tags are likely to contain the data. For example "INDI OCCU" normally contains the description of an occupation, even though there are other tags subordinate to this, while "INDI BIRT" never has any data, only its subordinate tags.

If the type of GEDCOM tag requires (ie. it is not a date), you must specify the maximum string length to be held in this field by entering a number between 1 and 255 in the Length box.

When all of these settings have been made, the Add button will be enabled. Click on the Add button to add the new field.

 
Changing the properties of an existing field

You may want to change the definition of an existing field. For instance, you may want to change the field name or the length of string which the field can hold.

Click on the field name in the Current fields list. The current properties of the field will appear in the "Field name", "Length" and "GEDCOM tag" boxes. Modify these properties as required (see "Adding a new field" above) and if the new properties are valid, click on the Change button.

 
Deleting a field:

You can delete an existing person or family field.

Click on the field name in the Current fields list. Click on the Delete button.

See also

Download genealogy software for family history research. Our free to try genealogy software is for family history research. Download TreeDraw to print charts from family tree software, it is free to try. We specialize in free to try genealogy software, available for download. Try our genealogy charting software for free. You can download genealogy software for family history. TreeDraw is a charting program for your family history. Download genealogy chart program for use with GEDCOM compatible software. Free 30-day trial. You can download genealogy software, free trial, to print your family history. Download genealogy software here for GEDCOM. This site is about genealogy and family history software with free trial software. TreeDraw imports GEDCOM files and produces genealogy charts. Print family trees with our free to try genealogy software. Our family history software is free to try and is used for genealogy. Genealogy software is sometimes mispelled as geneology software. TreeDraw is a genealogy chart program, download it here.