TreeDraw manual

TreeDraw site SpanSoft main site

TreeDraw

Getting Started

Introducing TreeDraw

Tutorials

Tutorial - Importing a tree

Tutorial - Using the drawing area

Tutorial - Printing a chart

Tasks

File handling

Starting a new chart

Opening an existing chart

Saving a chart

Saving a chart with a different name

Importing trees

Selecting a Kith and Kin Pro database

Importing from the same file again

Exporting the chart as an Adobe PDF file

Exporting the chart as a metafile

Exporting the chart as a bitmap

Preparing the chart for sending

Dropping files into TreeDraw

Changing the K&KPro database link names

Preferences | File settings

Tree import settings

Choosing import options

Preferences | Import visuals

Preferences | Import fields

Preferences | Dates

Preferences | Replace text

Preferences | Import profiles

Getting import visual styles from selection

Editing a chart

Selecting the pointer tool

Selecting chart elements

Selecting all chart elements

Adding text

Editing text

Adding lines and shapes

Adding pictures and graphics

Moving chart elements

Resizing chart elements

Joining lines to chart elements

Unjoining chart lines

Cutting to the clipboard

Copying to the clipboard

Pasting from the clipboard

Deleting chart elements

Grouping chart elements together

Ungrouping chart elements

Updating text automatically

Undoing the previous operation

Redoing the subsequent operation

Undoing several operations

Scaling the chart

Formatting

Setting text font

Setting text alignment

Setting text rotation

Setting word wrapping

Changing a text element's link to a K&KPro database

Selecting a family to use in a database link

Selecting a person to use in a database link

Setting the line style

Choosing a line style

Setting the shape fill pattern

Setting colours

Repeating the last format change

Getting default styles from selection

Alignment

Changing the order of chart elements

Aligning chart elements horizontally

Aligning chart elements vertically

Spacing chart elements evenly

Centring curved lines

Screen

Using the magnifier

Enlarging text

Turning the snap-to-grid on and off

Displaying page-breaks

Using the ruler

Moving around the drawing area

Zooming in and out

Searching for text

Turning the Colour Palette on and off

Turning the Chart View Control on and off

Turning the Button Bar on and off

Customising the Button Bar

Turning the Status Bar on and off

Preferences | Appearance

Printing

Printing a chart

Selecting pages to print

Setting page size/margins/orientation/footer

Setting a user-defined paper size

Setting up the printer

General

Setting preferences

Preferences | General

Exiting from the program

Backing-up your data

Checking for program updates

Using the Chart View Control

Reference

File menu

Edit menu

Format menu

Align menu

Tools menu

View menu

Options menu

Database fields

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

Kith and Kin Pro

GEDCOM

LDS

How to get support

How to contact us

Large-format printing service

Ordering / registration

Setting GEDCOM import options

If you are importing a tree from a GEDCOM file you can set some additional options after selecting the GEDCOM file.

TreeDraw will first read the file header from the selected file and display it so that you can verify that you have the correct file. You can now select several options which define how the GEDCOM file will be imported.

 
Display submitter/statistics when finished

Set this option if you want to see the name/address of the file submitter and how many records were read. This also gives you the chance to view any errors. Errors encountered during a GEDCOM import are always reported in the GEDERR.TXT file and you can view this file using Windows Notepad by clicking on the Errors button on the statistics form. Very often you will find errors reported which do not affect the integrity of the GEDCOM import. For example, "GIVN" and "SURN" tags are ignored by TreeDraw because a person's name is read from the "NAME" tag.

 
Put additional data in notes

"Additional data", is GEDCOM data which TreeDraw recognises, but there is no specific field set up for it in "Options | Preferences | GEDCOM". By setting this option any extra data will be added to the appropriate set of notes which you can add to person details or family details in "Options | Preferences | Import fields". See Supported GEDCOM syntax for a list of recognised extra data.

 
List additional data in GEDERR.TXT

By setting this option any extra data (see above) will be added to the GEDCOM import error file, GEDERR.TXT.

 
Convert invalid dates to text:

By setting this option any dates encountered which are invalid (eg. they do not conform to the GEDCOM standard date format DD MMM YYYY) are imported but are converted to text without being formatted.

 
Space out CONCed data for notes

Some programs export notes in GEDCOM files using a CONC tag to split long notes over several lines in the GEDCOM file. Sometimes the program splits the line at a space character, which is not allowed. This makes TreeDraw join two words together when it imports the file. To prevent this, set this option and an extra space character will be inserted at the beginning of every CONC line. This does not affect other types of data which also use the CONC tag.

 
Capitalise surnames

Set this option if you want TreeDraw to make all imported surnames have all capital letters, irrespective of the case in the GEDCOM file; eg. "Thomas Gordon" imports as "Thomas GORDON".

 
Duplicate tags

GEDCOM V5.5 requires that the first occurrence of a series of duplicated tags should be the one that is used in the program. For example, if a person has more than one name then there would be several NAME tags for him in the GEDCOM file. TreeDraw will use the first tag it comes across if the Use first occurrence option is set.

Some previous versions of GEDCOM accepted the last occurrence of multiple tags as the "genuine" one. If this is the case for the GEDCOM file you are importing, set the Use last occurrence option.

 
IBM (DOS) character set code page

GEDCOM files created with the IBMPC character set (usually from a DOS program) may have been written using one of the alternative DOS code pages. These pages are generally used in non-English speaking countries and contain extra characters such as "" to cover the additional diacritics used in their language.

You can select one of the following code pages and TreeDraw will convert the incoming extra characters into the appropriate ANSI characters for use in Windows. If you are in doubt about which code page was used to create the GEDCOM file, assume it was 437 English.

 
Code pages supported:

  • 437 English
  • 850 Latin I
  • 860 Portuguese
  • 863 Canadian-French
  • 865 Nordic

 
Multiple files

If the program encounters the end of a GEDCOM file before finding the TRLR record, it assumes that the file has been split over more than one disk (or file). You will be prompted to insert the disk containing the next file in sequence. GEDCOM files split into several files are named <filename>.GED, <filename>.G00, <filename>.G01, etc, where <filename>.GED is the filename originally specified for input.

 
Note on character sets:

TreeDraw will automatically detect which character set has been used to create the GEDCOM file. ANSI, ANSEL, Unicode, UTF-8, IBMPC (DOS) and Apple MAC are all supported. Please make sure that the GEDCOM file was written using one of these sets.

See also

Download genealogy software for family history research. Our free to try genealogy software is for family history research. Download TreeDraw to print charts from family tree software, it is free to try. We specialize in free to try genealogy software, available for download. Try our genealogy charting software for free. You can download genealogy software for family history. TreeDraw is a charting program for your family history. Download genealogy chart program for use with GEDCOM compatible software. Free 30-day trial. You can download genealogy software, free trial, to print your family history. Download genealogy software here for GEDCOM. This site is about genealogy and family history software with free trial software. TreeDraw imports GEDCOM files and produces genealogy charts. Print family trees with our free to try genealogy software. Our family history software is free to try and is used for genealogy. Genealogy software is sometimes mispelled as geneology software. TreeDraw is a genealogy chart program, download it here.